StealthBot.net: Having trouble connecting with Warcraft 2 - StealthBot.net

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Having trouble connecting with Warcraft 2

#1 User is offline   Yeow Icon

  • Newbie
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: October-07 09

Posted October 02, 2017 - 12:06 PM

This issue started around 24 hours ago, or that was the last time I was able to connect with W2BN. It has started hanging on Checking Version. I've tried switching IP addresses and BNLS servers but it keeps hanging. If I leave all the settings the same (useast.battle.net & bnls.mattkv.net) and switch to a D2 key, the bot will connect just fine. I was previously on build 482, bu have updated to 490 and the problem still persists.

 [06:55:51 AM] Connecting your bot...
 [06:55:51 AM] [BNLS] Connecting to the BNLS server at bnls.mattkv.net...
 [06:55:51 AM] [BNLS] Connected!
 [06:55:51 AM] [BNLS] Authorized!
 [06:55:51 AM] [BNCS] Connecting to the Battle.net server at useast.battle.net...
 [06:55:51 AM] [BNCS] Connected!
 [06:55:51 AM] [BNCS] Checking version...



Hashing is also failing for some reason, claiming that in cannot read something from CheckRevision.ini. Since I just installed 490, I presume that the CheckRevision file is as updated as possible. I've posted my CheckRevision file below. I also noticed that the file path for hashing is messed up. https://i.imgur.com/h3WIefB.png

 [06:49:55 AM] Connecting your bot...
 [06:49:55 AM] [BNCS] Connecting to the Battle.net server at useast.battle.net...
 [06:49:55 AM] [BNCS] Connected!
 [06:49:56 AM] [BNCS] Checking version...
 [06:49:56 AM] [BNCS] Could not read key "Exe" under [CRev_W2] from CheckRevision.ini, Update your configuration
 [06:49:56 AM] [BNCS] Local Hashing Failed
 [06:49:56 AM] All connections closed.


[CRev_Main]
LockdownPath=\Lockdown\

[CRev_W3]
Path=\WAR3\
Exe=war3.exe
Util=Storm.dll
Network=Game.dll
Screen=WAR3.bin

[CRev_SC]
Path=\STAR\
Exe=Starcraft.exe
Util=Storm.dll
Network=Battle.snp
Screen=STAR.bin

[CRev_W2]
Path=\W2BN\
Exe=Warcraft II BNE.exe
Util=Storm.dll
Network=Battle.snp
Screen=W2BN.bin

[CRev_D2]
Path=\D2DV\
Exe=game.exe
Util=NULL
Network=NULL
Screen=NULL

[CRev_D2X]
Path=\D2XP\
Exe=game.exe
Util=NULL
Network=NULL
Screen=NULL

[CRev_JS]
Path=\JSTR\
Exe=StarcraftJ.exe
Util=Storm.dll
Network=Battle.snp
Screen=JSTR.bin

[CRev_D1]
Path=\DRTL\
Exe=Diablo.exe
Util=Storm.dll
Network=Battle.snp
Screen=DRTL.bin

[CRev_DS]
Path=\DSHR\
Exe=Diablo_s.exe
Util=Storm.dll
Network=Battle.snp
Screen=DSHR.bin

[CRev_SS]
Path=\SSHR\
Exe=Starcraft_s.exe
Util=Storm.dll
Network=Battle.snp
Screen=SSHR.bin

This post has been edited by Yeow: October 02, 2017 - 12:11 PM


#2 User is online   Pyro Icon

  • Militant Asshole
  • Icon
  • Group: Administrators
  • Posts: 621
  • Joined: July-31 09

Posted October 02, 2017 - 02:38 PM

Can you send me a packet log?

Bot -> Tools -> Log StealthBot Packet Traffic
Pyro
StealthBot Developer
Chieftain of Clan BoT
Host of pyro.no-ip.biz

#3 User is offline   Yeow Icon

  • Newbie
  • Pip
  • Group: Members
  • Posts: 3
  • Joined: October-07 09

Posted October 02, 2017 - 03:02 PM

I've sent you a PM with the log.

#4 User is online   Pyro Icon

  • Militant Asshole
  • Icon
  • Group: Administrators
  • Posts: 621
  • Joined: July-31 09

Posted October 02, 2017 - 04:49 PM

This should be fixed now on the BNLS side.
Pyro
StealthBot Developer
Chieftain of Clan BoT
Host of pyro.no-ip.biz

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users