StealthBot.net: Checking if bot is disconnected - StealthBot.net

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Checking if bot is disconnected

#1 User is offline   Darknessattack2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 10
  • Joined: December-23 09

Posted October 07, 2010 - 05:24 AM

I am encountering an issue where my bot occasionally disconnects but doesn't realize that it has disconnected, as documented in http://www.stealthbo...g-flooding-out/

This is rather annoying, as if I don't check the message timestamps I could miss that it is disconnected and not reconnect it, so a script to recognize when this has happened and possibly reconnect it would be very nice.

#2 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted October 07, 2010 - 06:10 AM

Rather than scripting it, the devs need to fix it. I personally haven't had this issue in a long time and wonder if it was fixed in one of the build updates already. Try downloading the latest build http://www.stealthbo...lthBotSetup.msi

*Moved to tech support*

#3 User is offline   7thAce Icon

  • Find me elsewhere (Inactive)
  • Icon
  • Group: Tech Support Moderators
  • Posts: 1,292
  • Joined: August-18 09

Posted October 08, 2010 - 02:10 AM

I encountered this issue long ago, but nothing was ever done about it. I'll move it to the dev queue.
Posted Image
7thAce.no-ip.org: Posted Image
Official SB Tech @ Clan SBs USEast
Just a note to all you people who want to give Tech Support: Post with correct info (only - no info is better than wrong info), contribute to the topic, and be clear (the more explanation, the better).

#4 User is offline   Ribose Icon

  • Fire wants to be free.
  • Icon
  • Group: Global Moderators
  • Posts: 282
  • Joined: July-31 09

Posted October 08, 2010 - 02:12 AM

I can't fix something that I can't reproduce.
~Ribose
[ Download ] [ Wiki ] [ Support ] [ Scripting ]
[ Chrome ] [ Notepad++ ] [ fedora ]
[ Homepage ] [ BNLS ♯ ]

#5 User is offline   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted October 08, 2010 - 03:37 PM

Did you try using an anti-idle message?
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#6 User is offline   Darknessattack2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 10
  • Joined: December-23 09

Posted October 08, 2010 - 04:23 PM

View PostPhiX, on 08 October 2010 - 11:37 PM, said:

Did you try using an anti-idle message?


Yes, the bot is using an anti-idle message, a "/me" one, actually. For some reason it still disconnects without realizing that it has disconnected sometimes.

#7 User is offline   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted October 08, 2010 - 04:37 PM

By "it disconnects" you mean that the bot is still shown online, but there are no new messages on its screen, right? Or does it actually show a "[BNET] Disconnected." message?

In the first case an idle message should work as it's attempting to send text to Battle.net, which obviously is not possible when the connection has been lost. What happens when the bot would send the next message?
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#8 User is offline   Fallen-God Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 364
  • Joined: September-11 09

Posted October 08, 2010 - 04:42 PM

I don't think it is a Stealthbot problem.
The same can happen if you leave your Warcraft client idle for a few hours. You will only get the "Disconnected" message when you try to do something, otherwise it just looks like you sit in the channel where nothing happens (nobody leaves joins / nothing said).
Choose Functional.

#9 User is offline   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted October 08, 2010 - 04:49 PM

It is indeed a problem with the user's internet connection, but StealthBot should still realize that it is not connected to the server anymore.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#10 User is offline   tunefisch Icon

  • thunfisch/turnfisch
  • PipPipPip
  • Group: Members
  • Posts: 183
  • Joined: October-07 09

Posted October 08, 2010 - 09:47 PM

When SB freezes it won't recognize this too. Anyways if nobody knows at least more information is needed. What Scripts do you use? Where is the log...can't find it...? You can also post your config, except your cd-keys (remove cd-key&acc+pw). :)
Game Over! Final score: 29699

#11 User is offline   7thAce Icon

  • Find me elsewhere (Inactive)
  • Icon
  • Group: Tech Support Moderators
  • Posts: 1,292
  • Joined: August-18 09

Posted October 08, 2010 - 10:08 PM

Here's what happened to me:
http://www.stealthbo...g-flooding-out/
Posted Image
7thAce.no-ip.org: Posted Image
Official SB Tech @ Clan SBs USEast
Just a note to all you people who want to give Tech Support: Post with correct info (only - no info is better than wrong info), contribute to the topic, and be clear (the more explanation, the better).

#12 User is offline   Darknessattack2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 10
  • Joined: December-23 09

Posted October 09, 2010 - 06:31 AM

View PostPhiX, on 09 October 2010 - 12:37 AM, said:

By "it disconnects" you mean that the bot is still shown online, but there are no new messages on its screen, right? Or does it actually show a "[BNET] Disconnected." message?

In the first case an idle message should work as it's attempting to send text to Battle.net, which obviously is not possible when the connection has been lost. What happens when the bot would send the next message?


There is no "[BNET] Disconnected." message when this happens.

It doesn't send the next message if its an emote, but if its a regular anti-idle message without using bnet commands it sends it anyway(it appears on the screen).

It hasn't happened in a while though, last time it happened was about 4 days ago.

[Position]
LastSettingsPanel=5
Left=152
Top=144
Height=576
Width=847
Maximized=Y
[Main]
Product=3RAW
Username=
Password=
CDKey=
ExpKey=
Server=211.233.0.72
BNLSServer=phix.no-ip.org
Trigger={!}
ConfigVersion=5
UseRealm=N
ShowSplash=N
UTF8=N
MaxBacklogSize=10000
MaxLogFileSize=0
WhisperBack=N
Connectonstartup=Y
Minimizeonstartup=N
UseBackupChan=Y
DoNotUseDirectFList=N
URLDetect=Y
ShowOfflineFriends=Y
LogDBActions=N
LogCommands=N
UseBNLS=Y
Spoof=0
UseProxy=N
ProxyPort=
ProxyIP=
ProxyIsSocks5=N
UDP=N
ReconnectDelay=1000
Idles=Y
IdleWait=60
IdleType=msg
IdleMsg=/me has been up for %botup, host has been running for %cpuup
QuietTime=N
Protect=N
HomeChan=Clan YAP
UseAltBNLS=Y
IgnoreClanInvitations=N
UseWWs=N
BackupChan=Why did you kick bot?
Owner=Darknessattack2
HideBanMessages=N
[Other]
JoinLeaves=Y
Filters=N
FlashWindow=N
Timestamp=0
Logging=2
NoTray=N
NoAutocomplete=N
NoColoring=N
ProfileAmp=N
Mail=Y
DisablePrefix=N
DisableSuffix=N
AllowMP3=Y
UseGameConventions=Y
UseD2GameConventions=N
UseW3GameConventions=Y
ChatFont=Arial
ChatSize=8
ChanFont=Arial
ChanSize=8
Phrasebans=Y
IPBans=Y
BanEvasion=Y
KickOnYell=N
PlugBans=N
IdleBans=N
KickIdle=N
PeonBans=0
BanUnderLevel=0
BanD2UnderLevel=0
LevelBanMsg=You are below the required level for entry.
WhisperGreet=N
UseGreets=N
LastChannel=Why did you kick bot?
DisableVoidView=Y
MediaPlayer=Winamp
[StoredKeys]
Count=1
[Override]
W3VerByte=18



#13 User is offline   Darknessattack2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 10
  • Joined: December-23 09

Posted October 19, 2010 - 07:38 AM

Still disconnects without realizing it, happened 3 times or so in the past 3 days.

#14 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted October 28, 2010 - 06:39 PM

Just verified this is still happening in the newest build.

All 4 of my bots thought they were still online while they weren't. My ghost++ bot detected it and reconnected just fine.

#15 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted October 28, 2010 - 10:30 PM

Here's a script that "should" workaround it and reconnect your bot. The script relys on the packetreceived event.

http://www.stealthbo...connect-script/

I have it set to log all reconnect attempts as well as notate whether SB detected it or not. Might help to track what's causing it if people go back and see what happened around that time.

#16 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted November 08, 2010 - 12:54 AM

Ok, so I noticed this happening when a bot floods from commands. EG /fadd, /frem, etc...

The script I linked above will detect it and reconnect your bot. I'm going to make it an official release and remove Ribose's reconnect script for now.

#17 User is offline   SugarD-x Icon

  • Around Since 2.4...
  • PipPipPip
  • Group: Beta Testers
  • Posts: 179
  • Joined: August-20 09

Posted May 25, 2011 - 08:39 PM

I can confirm this issue still exists in the latest build. I have 7 bots successfully connected, some of which will randomly disconnect thinking they are IPBanned when they aren't, other times other bots will experience the above issue, and it cycles randomly between the bots, usually only affecting 1 or 2 at a time. This specific issue only seems to affect my WAR3/W3XP and D2XP bots. STAR and SEXP are unaffected at this time. Any thoughts?

#18 User is offline   SugarD-x Icon

  • Around Since 2.4...
  • PipPipPip
  • Group: Beta Testers
  • Posts: 179
  • Joined: August-20 09

Posted May 28, 2011 - 07:37 PM

View PostAwaKening, on October 28, 2010 - 03:30 PM, said:

Here's a script that "should" workaround it and reconnect your bot. The script relys on the packetreceived event.

http://www.stealthbo...connect-script/

I have it set to log all reconnect attempts as well as notate whether SB detected it or not. Might help to track what's causing it if people go back and see what happened around that time.

Sorry for the bump, but I can confirm that this script COMPLETELY fixes the issue, even when the bot doesn't see itself as disconnected. Maybe this should be implemented into the bot itself. I was checking out the script and it's by no means large or complex at all, so I don't see why it shouldn't be added.

Also just a suggestion for the script itself, maybe it should be updated to have the log save to the logs folder. ;)

This post has been edited by SugarD-x: May 28, 2011 - 07:38 PM


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users