StealthBot.net: ReloadConfig - StealthBot.net

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

ReloadConfig

#1 User is offline   NuStiuJuca Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 24
  • Joined: June-12 10

Posted September 24, 2010 - 08:25 PM

Can somebody help me with this procedure: Call frmChat.ReloadConfig(DoNotLoadFontSettings) ? I need a script that reloads config once in 5 minutes or at least tell me how to use it >.< i`m a bit confused uith that param. Please help :) .

#2 User is offline   Novynn Icon

  • Silver Member
  • PipPipPipPipPip
  • Group: Senior Members
  • Posts: 873
  • Joined: October-07 09

Posted September 24, 2010 - 08:34 PM

That's the internal routine, we have to use SSC...

So what you want is "Call ReloadSettings()". The argument is optional and if set to 0, it reloads font settings as well as opposed to 1 if you don't.

Personally, I'd just leave the argument out :).

#3 User is offline   Dragon_Legion Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 423
  • Joined: October-08 09

Posted September 24, 2010 - 08:45 PM

you can do this with a script and a timer easily.

and why would you reload the config every 5 minutes? It should only be done if you changed something in the Config.ini file

#4 User is offline   NuStiuJuca Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 24
  • Joined: June-12 10

Posted September 24, 2010 - 08:46 PM

[23:46:44] Error Number: 449 Description: Argument not optional

:-? In this case what argument should i put so it won`t affect anything ?
I made a "KickOnBadVersion" in C++ that combined with the script.txt kicks all users that don`t have the right version of the game, until they update. Also the program is executed once every 5 minutes by a MS-DoS program that auto-executes "KickOnBadVersion" and itself so it updates to delete the users that updated and put in the users that were found new. The only problem is that i have to reload the config manualy. I made all those with the basics i leaned in 2 years of programming in pascal and half year in C++. I tried to make a plugin so it would verify the version on the moment the user joined but didn`t really go well O.o .

This post has been edited by NuStiuJuca: September 24, 2010 - 08:53 PM


#5 User is offline   Novynn Icon

  • Silver Member
  • PipPipPipPipPip
  • Group: Senior Members
  • Posts: 873
  • Joined: October-07 09

Posted September 24, 2010 - 09:08 PM

Uh... woops. That's strange, I'm sure it was optional last time I used it...

Just use: "Call ReloadSettings(0)".




EDIT: Wait what? It doesn't confirm that it has reloaded them... this is really strange. Just wait till a dev looks at this topic.

#6 User is offline   NuStiuJuca Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 24
  • Joined: June-12 10

Posted September 24, 2010 - 09:16 PM

Ye.. about that, last time a 'dev' looked on my topic was moved to the trash can and didn`t got any help. I`m using it on pvpgn so the best version of the bot is out dated... it`s 2.6r3, i saw that on 2.7 they have the procedure reloadconfig() but all the things i`ve done so far in 2.6r3 have to be changed to work to 2.7 and i don`t think i know how to do it :-??. Well, last time i tried to use 2.7 on broodwar it gave me an error and as always nobody helped because they don`t support pvpgn and i use 2.6r3 because it works... and it`s a lil ironic because they won`t help me with it and they just say 'update to 2.7 (so you won`t be able to use SB anymore and we won`t help you > :) )' :) . Well, thanks for trying .

Dev:"2.) We do not support v2.6R3.

And I do not provide support via PM."

Like i said ... update to 2.7 so it won`t work anymore :).

This post has been edited by NuStiuJuca: September 24, 2010 - 09:20 PM


#7 User is offline   The-Black-Ninja Icon

  • The Sex
  • Icon
  • Group: Scripting Moderators
  • Posts: 2,526
  • Joined: August-01 09

Posted September 24, 2010 - 10:47 PM

We don't provide support for PvPGN because they are not official battle.net servers. The bot has the capability to connect and to run on them, but there are limitations as to what you can do, which is why we don't bother with it. So you have a trade off; upgrade so you can reload your config, but it might not work on your PvPGN, or don't upgrade and you can't reload your config automatically.

#8 User is offline   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted September 24, 2010 - 10:48 PM

StealthBot v2.7 does work on PvPGN servers. You just have to know what you're doing. And it's not our problem that you are using the bot on a server that is not supported on this site.

Use the latest stable version and an official Battle.net server and you will receive full support for it.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#9 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted September 25, 2010 - 12:46 AM

Just as a note, 2.7 has better support for PvPGN then 2.6r3 does.
But like its been stated, PvPGN isn't supported.
Erin Go Bragh!
Posted Image

#10 User is offline   NuStiuJuca Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 24
  • Joined: June-12 10

Posted September 25, 2010 - 01:05 AM

Ok. Let`s see, i upgraded SB to 2.7 and i made it work pretty good but i can`t use any plugin or script because they don`t work. Now please tell me how can i reload PluginSystem.txt automaticaly. I tried a few things but no result -.-.

This post has been edited by NuStiuJuca: September 25, 2010 - 01:06 AM


#11 User is offline   The-Black-Ninja Icon

  • The Sex
  • Icon
  • Group: Scripting Moderators
  • Posts: 2,526
  • Joined: August-01 09

Posted September 25, 2010 - 01:08 AM

Perhaps you should read the sticky in the scripting forum on how to add scripts to your bot because it explains that you no longer need PluginSystem.txt

#12 User is offline   NuStiuJuca Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 24
  • Joined: June-12 10

Posted September 25, 2010 - 08:48 AM

Ok and how should that help me to auto-reload a script ?! Just give me the function or something -.-. Never mind, i`ve done it with the 2.6r3 ... Usless new version -.-

This post has been edited by NuStiuJuca: September 25, 2010 - 08:55 AM


#13 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted September 25, 2010 - 09:08 AM

I have moved this topic to the Trash Can.
If you have any questions or concerns as to why this topic was trashed, please contact me privately through the board's personal messaging service.
Recreating this thread or discussing these actions publicly is against the rules and will be grounds for a warning. Please do not do it.
Erin Go Bragh!
Posted Image

#14 User is offline   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted September 25, 2010 - 09:28 AM

You should probably downgrade to Windows 98, too, because old software works better on it. Screw the new useless Windows versions.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#15 User is offline   Ribose Icon

  • Fire wants to be free.
  • Icon
  • Group: Global Moderators
  • Posts: 282
  • Joined: July-31 09

Posted September 25, 2010 - 08:08 PM

View PostNuStiuJuca, on 25 September 2010 - 04:48 AM, said:

Ok and how should that help me to auto-reload a script ?! Just give me the function or something -.-. Never mind, i`ve done it with the 2.6r3 ... Usless new version -.-

...ReloadScript() (wiki) anyone?
~Ribose
[ Download ] [ Wiki ] [ Support ] [ Scripting ]
[ Chrome ] [ Notepad++ ] [ fedora ]
[ Homepage ] [ BNLS ♯ ]

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users