StealthBot.net: StealthBot Command - Greet - Bugged - StealthBot.net

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

StealthBot Command - Greet - Bugged The command does not work.

#1 User is offline   FloodKhelbyn Icon

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: January-10 10

Posted January 21, 2010 - 07:10 PM

The command "greet" for StealthBot does not appear to be working. The syntax is "#greet <text>". However, this is completely ineffective. It does nothing. "#greet on" and "#greet off" still work, but you can not set a greet message by command; you have to do it manually through the configuration settings. "#greet set blah" works, in a limited fashion. It only sets the greeting using the text up to the first space. For example, if you use "#greet set Howdy there dude." then only "Howdy" will be shown when the greeting is called.

Also, a small thing: when you "#greet disable", there's a couple typos. The text presented is "Gree messages diabled".

I don't really require a response on this - I'm fine using the configuration settings and "#greet set <text>" for now. But I think it'd be best if ya'll could find out why it's not working and get it working for the next release. Thanks
Flood]Khelbyn, Trivaethon (1) of the Almighty Flood!

Channel: OP xXFloodXx Website: jointheflood.webs.com

#2 User is offline   Tuck Icon

  • Full Member
  • PipPipPip
  • Group: Banned
  • Posts: 587
  • Joined: August-31 09

Posted January 21, 2010 - 08:18 PM

If you read about the greet command you will se this:
.Greet <SubCommand> [Value]
Enables, disables, or changes the settings of, a welcome message.

<SubCommand> (Word)
The subcommand to use, must be: 'on', 'off', or 'whisper'

[Value] (Word)
The whisper subcommand to use, must be: 'on', or 'off'


This a fun bug.

Quote

/Greet off
[09:01:36 PM] Gree messages diabled.
/Greet whisper off
[09:17:47 PM] Gree messages will no longer be whispered.

-Tuck

#3 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted January 22, 2010 - 01:01 AM

Working as intended.
Use SetGreet
Erin Go Bragh!
Posted Image

#4 User is online   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted January 22, 2010 - 01:13 PM

View PostHdx, on 22 January 2010 - 02:01 AM, said:

Working as intended.
Use SetGreet
Definitely not working as intended. First of all, there is no "setgreet" command. Secondly, if you check the old readme, the syntax in the old version was "/greet <message>" and I can't recall that it has ever been changed. The commands and their behavior remained the same for backwards compatibility. And how is it working as intended when "/greet set <word>" works? That doesn't make sense at all, sorry.

@FloodKhelbyn: Thanks for reporting this issue.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#5 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted January 23, 2010 - 12:06 AM

I thought I changed it when I wen't through and changed the commands. I know I discussed it it someone.
But anyways, just use /greet set <greet>
It is a less ambiguous command then /greet <greet>
If we supported the old way you'd get shit like /greet On tuesday .... /greet Set the bot to ... etc... but meh. If one of the other devs wanna waist time go for it!
Erin Go Bragh!
Posted Image

#6 User is offline   nate Icon

  • Full Member
  • PipPipPip
  • Group: Moderators
  • Posts: 147
  • Joined: August-09 09

Posted January 23, 2010 - 12:09 AM

This is working as intended...The commands were rewritten and tested as Hdx outlined their intended behavior, now is not the time to be saying you don't like it that way...

#7 User is online   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted January 23, 2010 - 01:50 AM

View PostFloodKhelbyn, on 21 January 2010 - 08:10 PM, said:

It only sets the greeting using the text up to the first space. For example, if you use "#greet set Howdy there dude." then only "Howdy" will be shown when the greeting is called.
I doubt this is intended. You can't set a greet message with more than 1 word via command.

And commands.xml is missing the subcommand "set" then.

@nate: I'm sorry that I didn't have the time to check each single command if it was still behaving as before. I used common sense and simply assumed it. My bad then.

If it's "/greet set <message>" now, I'm fine with that. But it needs to be documented somewhere. How would I know that if the subcommand isn't even listed anywhere? And it needs to work properly.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

#8 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted January 23, 2010 - 02:11 AM

Thats why I said it was /setgreet I assumed you check /greet set, its been a long time since i've even looked at the command.
If I ever feel like it i'll look at it.
  <command name="greet">
    <aliases />

    <documentation>
      <description>
        Enables, disables, or changes the settings of, a welcome message.
      </description>
    </documentation>

    <arguments>
      <argument name="SubCommand" type="word">
        <documentation>
          <description>
            The subcommand to use, must be: 'on', 'off', 'set', 'status', or 'whisper'
          </description>
        </documentation>
      </argument>

      <argument name="Value" type="string" optional="1">
        <documentation>
          <description>
            Must be: 'on', or 'off' when SubCommand is 'Whisper', else the greet message to set.
          </description>
        </documentation>
      </argument>
    </arguments>

    <access>
      <rank>80</rank>
      <flags>
        <flag>M</flag>
      </flags>
    </access>
  </command>

Problem was 'value' was set to word, not String.
Erin Go Bragh!
Posted Image

#9 User is offline   Tuck Icon

  • Full Member
  • PipPipPip
  • Group: Banned
  • Posts: 587
  • Joined: August-31 09

Posted January 23, 2010 - 02:13 AM

View PostHdx, on 23 January 2010 - 02:11 AM, said:

Thats why I said it was /setgreet I assumed you check /greet set, its been a long time since i've even looked at the command.
If I ever feel like it i'll look at it.


you should fix the miss spelling i highlighted in second post to if ya choose to look at it again
-Tuck

#10 User is offline   Hdx Icon

  • Hdx
  • Icon
  • Group: Administrators
  • Posts: 1,359
  • Joined: July-31 09

Posted January 23, 2010 - 03:16 AM

That was fixed several builds back.
Erin Go Bragh!
Posted Image

#11 User is offline   Tuck Icon

  • Full Member
  • PipPipPip
  • Group: Banned
  • Posts: 587
  • Joined: August-31 09

Posted January 23, 2010 - 10:47 AM

View PostHdx, on 23 January 2010 - 03:16 AM, said:

That was fixed several builds back.


What builds im using 2.7.1 >_>
-Tuck

#12 User is online   PhiX Icon

  • Notice the ownage.
  • Icon
  • Group: Administrators
  • Posts: 8,388,607
  • Joined: July-31 09

Posted January 23, 2010 - 06:35 PM

View PostTuck, on 23 January 2010 - 11:47 AM, said:

What builds im using 2.7.1 >_>
Read pinned topics.
PhiX

BNLS: phix.no-ip.org

Please refrain from sending me personal messages regarding technical support issues. Use the forums, that is what they are there for.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users