StealthBot.net: SharedQ Script - StealthBot.net

Jump to content

  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

SharedQ Script version 2.1.9

#51 User is offline   hans2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: October-23 10

Posted October 24, 2010 - 10:01 AM

i am runing 4 shared bots atm and get this error from time to time

[12:00:12 PM] Scripting runtime error '70' in SharedQ: (line 480; column 1)
[12:00:12 PM] Erlaubnis verweigert.
[12:00:12 PM] Offending line: >>
[12:00:12 PM] Scripting runtime error '70' in SharedQ: (line 180; column 2)
[12:00:12 PM] Erlaubnis verweigert.
[12:00:12 PM] Offending line: >>

#52 User is offline   hans2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: October-23 10

Posted October 24, 2010 - 11:17 AM

View Posthans2, on 24 October 2010 - 10:01 AM, said:

i am runing 4 shared bots atm and get this error from time to time

[12:00:12 PM] Scripting runtime error '70' in SharedQ: (line 480; column 1)
[12:00:12 PM] Erlaubnis verweigert.
[12:00:12 PM] Offending line: >>
[12:00:12 PM] Scripting runtime error '70' in SharedQ: (line 180; column 2)
[12:00:12 PM] Erlaubnis verweigert.
[12:00:12 PM] Offending line: >>


this script pretty much sucks as it seems you distribute the load random on all shared bots so in bad case one bot get too much and all flood
the access error looks like you multiply access the same file read/write which gives ofc errors when 2 bots want to read/write in same time

I will write a proper sharedq script today when i am back from shopping

#53 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted October 25, 2010 - 06:17 PM

View Posthans2, on 24 October 2010 - 05:17 AM, said:

this script pretty much sucks as it seems you distribute the load random on all shared bots so in bad case one bot get too much and all flood
the access error looks like you multiply access the same file read/write which gives ofc errors when 2 bots want to read/write in same time

I will write a proper sharedq script today when i am back from shopping


I can't wait for your "proper" script. Show us your skillz.

To address your claim about a bot getting overloaded and flood, maybe you should read my script again, because this is untrue.

Q.setDelay Len(Message)    '// used when a message is sent as well as when one is added to the shared file

'// checked in the timer sub to prevent exactly what you accuse my script of doing
If Queued Then
     Queued = Abs(Queued)-1
     Exit Sub
End If


#54 User is offline   hans2 Icon

  • Junior Member
  • PipPip
  • Group: Members
  • Posts: 15
  • Joined: October-23 10

Posted October 28, 2010 - 02:16 PM

View PostAwaKening, on 25 October 2010 - 06:17 PM, said:

I can't wait for your "proper" script. Show us your skillz.

To address your claim about a bot getting overloaded and flood, maybe you should read my script again, because this is untrue.

Q.setDelay Len(Message)    '// used when a message is sent as well as when one is added to the shared file

'// checked in the timer sub to prevent exactly what you accuse my script of doing
If Queued Then
     Queued = Abs(Queued)-1
     Exit Sub
End If



techincal it shoudl be like this

when u output 10 lines with 5 bots it shoudl be


bot1 line1
bot2 line2
bot3 line3
bot4 line4
bot5 line5
bot1 line6
bot2 line7
bot3 line8
bot4 line9
bot5 line10

so looking into channel window its easy to see if thats working or not and in sharedq case its not working
furthermore i guess access on the queue file is not correct as script can cause accesserror abviously when 2 scripts want to r/w the file at same time

even ur sampleoutput shows how hard the script fails

/exec For i=0 to 20: AddQ i: Next
[09:30:34 AM] <RnR_Bot4> 0
[09:30:35 AM] <RnR_Bot3> 1
[09:30:35 AM] <RnR-Bot2> 2
[09:30:36 AM] <RnR_Bot3> 3
[09:30:36 AM] <RnR-Bot2> 4
[09:30:37 AM] <RnR_Bot4> 5
[09:30:37 AM] <RnR_Bot3> 6
[09:30:39 AM] <RnR_Bot4> 7
[09:30:39 AM] <RnR-Bot2> 8
[09:30:40 AM] <RnR_Bot> 9
[09:30:42 AM] <RnR_Bot4> 10
[09:30:43 AM] <RnR-Bot2> 11
[09:30:44 AM] <RnR_Bot3> 12
[09:30:45 AM] <RnR-Bot2> 13
[09:30:46 AM] <RnR_Bot3> 14
[09:30:47 AM] <RnR-Bot2> 15
[09:30:48 AM] <RnR_Bot4> 16
[09:30:49 AM] <RnR-Bot2> 17
[09:30:50 AM] <RnR_Bot4> 18
[09:30:51 AM] <RnR_Bot3> 19
[09:30:52 AM] <RnR_Bot4> 20
[09:30:53 AM] <RnR_Bot> Code Successfully Executed

#55 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted October 28, 2010 - 06:45 PM

When using Queue.RemoveItemById(id), the message is removed, but the delay is NOT. This is hard coded into stealth and the only way I can work around it is to delay grabbing a message everytime one is sent to the queue; otherwise you will have some long delays. Each bot is grabbing a message as soon as its queue is empty, so it doesn't matter what order the output is in.

You obviously have very little experience with Stealth, or even with scripting. You claimed that you would write something better about a week ago now, so where is it?



#56 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted November 23, 2010 - 07:24 PM

Update to work around some annoying Stealth functionality.

Removing a message from the internal queue does NOT remove the delay it adds (stealthbot annoyance/bug); therefore I've made the script to send the first message as long as the queue is empty. This means that you may see your main bot outputting most of the messages, but it should speed things up especially in long messages.



#57 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted March 10, 2012 - 02:01 PM

This script seems to have inverted the triggers for my bots. The main bot's trigger was "!" and now responds to "=". The secondary bot's trigger was "=" and now responds to "!".

This post has been edited by Plutonium239: March 10, 2012 - 02:01 PM

Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#58 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted March 12, 2012 - 03:25 AM

View PostPlutonium239, on March 10, 2012 - 08:01 AM, said:

This script seems to have inverted the triggers for my bots. The main bot's trigger was "!" and now responds to "=". The secondary bot's trigger was "=" and now responds to "!".


You seem to be confused as to how this works.

Your bots will be sharing a common queue. Any bot will respond to any trigger. There are settings you can adjust if it affects moderation messages and/or whispers. Please read the initial post on settings if you don't understand. All settings are in scripts.ini

#59 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted July 28, 2012 - 02:29 AM

Okay, So i have 4 stealthbots online. 2 are in Clan MIB. The other 2 are in Clan MIB2. I have changed the settings so the 2 bots in Clan MIB will only share queue with eachother in that channel, as well as those in Clan MIB2 share while only in Clan MIB2, however, they are sharing the queue across the channels, I am not getting any errors. Any reason why this should be occurring?

The following is from Clan MIB:

[10:19:01 PM] <BanHammer[MiB]> test spam
[10:19:03 PM] <BanHammer[MiB]> test spam
[10:19:05 PM] <BanHammer[MiB]> test spam
[10:19:07 PM] <BanHammer[MiB]> test spam
[10:19:09 PM] <BanHammer[MiB]> test spam
[10:19:11 PM] <BanHammer[MiB]> test spam
[10:19:13 PM] <BanHammer[MiB]> test spam
[10:19:15 PM] <BanHammer[MiB]> test spam
[10:19:15 PM] <Clan.MiB> test spam
[10:19:16 PM] <BanHammer[MiB]> test spam
[10:19:18 PM] <BanHammer[MiB]> test spam
[10:19:19 PM] <Clan.MiB> test spam
[10:19:20 PM] <BanHammer[MiB]> test spam
[10:19:22 PM] <BanHammer[MiB]> test spam
[10:19:24 PM] <BanHammer[MiB]> test spam
[10:19:24 PM] <Clan.MiB> test spam
[10:19:26 PM] <BanHammer[MiB]> test spam
[10:19:28 PM] <BanHammer[MiB]> test spam
[10:19:29 PM] <BanHammer[MiB]> test spam


The Following is from Clan MIB2:

[10:19:06 PM] <ClanMiB2> test spam
[10:19:08 PM] <ClanMiB2> test spam
[10:19:17 PM] <ClanMiB2> test spam
[10:19:23 PM] <BanHammer[MiB2]> test spam
[10:19:28 PM] <ClanMiB2> test spam
[10:19:31 PM] <ClanMiB2> test spam


Any help or suggestions or fixes to the script would be greatly appreciated.
Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#60 User is offline   RosieSuckedMe Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 251
  • Joined: March-17 11

Posted July 28, 2012 - 04:21 AM

Quote

I have changed the settings so the 2 bots in Clan MIB will only share queue with eachother in that channel, as well as those in Clan MIB2 share while only in Clan MIB2

What setting is that if I may ask? I don't recall the script having a such setting.

- Try changing the name of the file the two bots @ Clan MIB2 share into something diffrent from the other bots. (you'll have to do this inside the script however!)

This post has been edited by RosieSuckedMe: July 28, 2012 - 04:22 AM


#61 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted July 28, 2012 - 05:29 AM

I thought that is what the part that I highlighted in bold did. Also can you walk me through it, I have no idea what the fuck I am doing.(only just started learning BASIC)
[SharedQ]
version=2.1.9
maxMessageLen (info)=Messages over this length will be split. (In most cases this shouldn't be changed) Don't set higher than 223!
maxMessageLen=223
sharePublic (info)=Y/N share public output messages
sharePublic=Y
shareWhispers (info)=Y/N share whispered messages
shareWhispers=Y
shareEmotes (info)=Y/N share emoted messages
shareEmotes=Y
shareMod (info)=Y/N share Moderation commands
shareMod=Y
whisperUsers (info)=Whispers to any of these users will not be shared (Seperate users with a space)
whisperUsers=
sqChannel (info)=Set a channel name here if you want to share your queue only while in this channel
sqChannel=

This post has been edited by Plutonium239: July 28, 2012 - 05:42 AM

Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#62 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted July 31, 2012 - 02:15 AM

View PostRosieSuckedMe, on July 28, 2012 - 12:21 AM, said:

What setting is that if I may ask? I don't recall the script having a such setting.

- Try changing the name of the file the two bots @ Clan MIB2 share into something diffrent from the other bots. (you'll have to do this inside the script however!)

Tried that, it did not work.
Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#63 User is offline   AwaKening Icon

  • how do ya like me now
  • Icon
  • Group: Scripting Moderators
  • Posts: 977
  • Joined: August-20 09

Posted August 04, 2012 - 05:35 AM

Find this line in the script
    queueFile = CreateObject("Wscript.Shell").ExpandEnvironmentStrings("%AppData%")&"\sharedq.txt"


You will need to change the filename in each bot you want to share and match them. Something like this
    queueFile = CreateObject("Wscript.Shell").ExpandEnvironmentStrings("%AppData%")&"\mib.txt"


And in your other bots in the 2nd channel to something like this:
    queueFile = CreateObject("Wscript.Shell").ExpandEnvironmentStrings("%AppData%")&"\mib2.txt"



I would just make this an added feature, but I've pretty much quit wc3 and scripting. I just check in here once in a while.

#64 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted August 04, 2012 - 06:32 PM

Thanks, your help is much appreciated. Blizzard wiped my clans with the roll back so I will have to wait to test this. I had a clan b4 they wiped all the clans, but I am going to let it die in favor of a new one I made, hopefully my clan is full enough within the next few months to warrant an expansion clan again(it probably will be within 2 months). <_<
Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#65 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted February 18, 2013 - 07:08 PM

Hey, I am getting this error a lot. Any help would be appreciated.
[02:08:03 PM] Scripting runtime error '70' in SharedQ: (line 426; column 1)
[02:08:04 PM] Permission denied
[02:08:04 PM] Offending line: >>
[02:08:04 PM] Scripting runtime error '70' in SharedQ: (line 146; column 2)
[02:08:04 PM] Permission denied
[02:08:04 PM] Offending line: >>
Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

#66 User is offline   Plutonium239 Icon

  • Full Member
  • PipPipPip
  • Group: Members
  • Posts: 124
  • Joined: January-29 12

Posted February 20, 2013 - 11:43 PM

[06:20:00 PM] Scripting runtime error '-2147023672' in SharedQ: (line 506; column 1)
[06:20:01 PM] Offending line: >>
[06:20:01 PM] Scripting runtime error '-2147023672' in SharedQ: (line 131; column 21)
[06:20:01 PM] Offending line: >>
[06:19:52 PM] Scripting runtime error '70' in SharedQ: (line 506; column 1)
[06:19:52 PM] Permission denied
[06:19:52 PM] Offending line: >>
[06:19:52 PM] Scripting runtime error '70' in SharedQ: (line 190; column 2)
[06:19:53 PM] Permission denied
[06:19:53 PM] Offending line: >>

The script started throwing these errors non-stop and bots wont do anything with the script active now, whenever I turn the script back on, it throws these errors again...
[06:41:24 PM] Scripting runtime error '70' in SharedQ: (line 392; column 1)
[06:41:24 PM] Permission denied
[06:41:24 PM] Offending line: >>
[06:41:24 PM] Scripting runtime error '70' in SharedQ: (line 189; column 1)
[06:41:24 PM] Permission denied
[06:41:24 PM] Offending line: >>
Posted Image
http://images.cheezb...0f14e916b04.jpg Picture is way too big for a signature! -PhiX

  • (3 Pages)
  • +
  • 1
  • 2
  • 3
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users