IPB

Welcome Guest ( Log In | Register )

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

2 Pages V  1 2 >  
Reply to this topicStart new topic
> ghlGhostHostList, (keywords: warcraft war bcp war3)
Call
post Apr 9 2009, 04:22 AM
Post #1


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



Ghost Host List: v2.8

Author: Call
Explaination: Keeps track of your ghost bots and display the new games they hosted.
Configuration: All listed inside the code, very easy to configure.
BotVersion Required: 2.6R3+
Quick Download: Attached File  ghl2.plug ( 5.81k ) Number of downloads: 518


Update News: Will be using old data until it receives new data.

CODE
'ghl
'2.8
'&Ghost Host List:Call:Keeps track of your ghost bots and display the new games they hosted.
'&games - dispaly current games(can be changed and disabled)
'&40691
'&Please read the configurations comments and configure the plugin for your needs.:Please report all bugs/errors found.:Please suggest all you think would be great for the plugin on the plugin home topic.:All ghost bots must be on the stealthbot's friend list or else this will not work.
'Assisted by: None

'// Ghost Host List 2 . 8
private const vinterval = 20 'Timer interval(seconds) for whispers to be sent
private const vghost = "username1|username2" 'Ghost's username seperate with |
private const vghostcommand = ".getgames" 'Command to whisper
private const vdisplay = "%game(%used/%size)" 'New game display
private const vdisplay2 = "No games available." 'No new games
private const vtimerdisplay = 0 'Use timer to display new games
private const vtimerinterval = 20 'Time btw new game lists
private const vcommanddisplay = 1 'Use command to display new games
private const vcommandaccess = -1 'Access required to use display command
private const vcommand = "games" 'Command to display new games
private const vcommandspam = 5 'Anti-Spam seconds before command can be used again

'// Game [%game : %username : %used/%size : %minutes] is in the lobby and there are %used2/%size2 other games in progress.
'// %spots - gives you the number of spots that is open in the game can be used in vdisplay.

public ghlL, ghlA, ghlO, ghlB
ghlL = vdisplay2
ghlO = ""
ghlA = false
ghlB = false

sub ghl_event_load()
TimerInterval "ghl", "ghost", int(vinterval)
TimerInterval "ghl", "list", int(vtimerinterval)
TimerInterval "ghl", "spam", int(vcommandspam)
TimerEnabled "ghl", "ghost", true
TimerEnabled "ghl", "spam", false
if int(vtimerdisplay) = 1 then TimerEnabled "ghl", "list", true else TimerEnabled "ghl", "list", false
end sub

sub ghl_ghost_timer()
dim TempCount : TempCount = 0
for x = 0 to UBound(Split(vghost, "|"))
if GetPositionByName(Split(vghost, "|")(x)) > 0 then
TempCount = TempCount + 1
end if
next
ghlO = ghlL
ghlL = vdisplay2
ghlB = true
if Int(UBound(Split(vghost, "|")) + 1) = Int(TempCount) then exit sub
AddQ "/f m " & vghostcommand
end sub

sub ghl_list_timer()
dim Games
if not ghlL = vdisplay2 then
Games = "Games: " & left(ghlL, len(ghlL) - 2)
else
Games = vdisplay2
end if
If ghlB and Not ghlO = vdisplay2 Then Games = "Games: " & left(ghlO, len(ghlO) - 2)
dsp 1, Games, username, vbRed
end sub

sub ghl_spam_timer()
ghlA = false
TimerEnabled "ghl", "spam", false
end sub

sub ghl_event_whisperfromuser(username, flags, message)
dim TempBoolean : TempBoolean = false
For x = LBound(Split(vghost, "|")) to UBound(Split(vghost, "|"))
if LCase(Username) = LCase(Split(vghost, "|")(x)) then
TempBoolean = true
exit for
end if
next
if not TempBoolean then exit sub
ghlB = false
if instr(lcase(message), "is in the lobby") then
dim TempString
TempSplit1 = Replace(message, "Game [", "")
TempSplit = Split(TempSplit1, "] is")(0)
Game = Split(TempSplit, " : ")(0)
Username = Split(TempSplit, " : ")(1)
Minutes = Split(TempSplit, " : ")(3)
TempSplit = Split(TempSplit, " : ")(2)
Used = Split(TempSplit, "/")(0)
Size = Split(TempSplit, "/")(1)
Spots = Int(Int(Size) - Int(Used))
TempSplit1 = split(message, " in the lobby and there are ")(1)
TempSplit = split(TempSplit1, " other games in progress.")(0)
Used2 = Split(TempSplit, "/")(0)
Size2 = Split(TempSplit, "/")(1)
TempString = vdisplay
TempString = replace(TempString, "%game", Game)
TempString = replace(TempString, "%username", Username)
TempString = replace(TempString, "%used2", Used2)
TempString = replace(TempString, "%size2", Size2)
TempString = replace(TempString, "%used", Used)
TempString = replace(TempString, "%size", Size)
TempString = replace(TempString, "%minutes", Minutes)
TempString = replace(TempString, "%spots", Spots)
if InStr(ghlO, Game) <= 0 then dsp 1, "New Game: " & TempString, botvars.username, vbgreen
if ghlL = vdisplay2 then ghlL = TempString & ", " else ghlL = ghlL & TempString & ", "
end if
end sub

sub ghl_event_usertalk(username, flags, message, ping)
if ghlA then exit sub
if int(vcommanddisplay) = 0 then exit sub
getdbentry username, access, flags
if access < vcommandaccess then exit sub
if lcase(message) = lcase(BotVars.Trigger & vcommand) then
ghlA = true
dim Games
if not ghlL = vdisplay2 then
Games = "Games: " & left(ghlL, len(ghlL) - 2)
else
Games = vdisplay2
end if
If ghlB and Not ghlO = vdisplay2 Then Games = "Games: " & left(ghlO, len(ghlO) - 2)
dsp 1, Games, username, vbRed
TimerEnabled "ghl", "spam", true
end if
end sub


This post has been edited by The-Black-Ninja: Jun 20 2009, 04:42 PM


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Instinct121
post Jun 16 2009, 05:17 PM
Post #2


Jr. Member
**

Group: Members
Posts: 12
Joined: 16-June 09
Member No.: 51,626



Looks nice. To clarify, it's only intended use is to track games hosted by multiple GHost bots, correct?


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 18 2009, 04:52 PM
Post #3


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



I think this new version can be used to track one bot, or multiples, I know the old one could only do 1 bot at a time.

Will this work correctly for the beta or?

EDIT: Seems to work, but I noticed on this version if uses the /f msg instead of wispering the bot... :-\


I think there is a bug, it shouldn't keep doing the /f msg over and over after the bot joins the channel again right?

QUOTE
[07:23:26 PM] <To your friends> !getgames
[07:23:27 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #54 : c0rr0sive : 9/12 : 8m] is in the lobby and there are 2/3 other games in progress.
[07:23:41 PM] <To your friends> !getgames
[07:23:41 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #54 : c0rr0sive : 9/12 : 9m] is in the lobby and there are 2/3 other games in progress.
[07:23:56 PM] <To your friends> !getgames
[07:23:56 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #54 : c0rr0sive : 9/12 : 9m] is in the lobby and there are 2/3 other games in progress.
[07:24:11 PM] <To your friends> !getgames
[07:24:11 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #54 : c0rr0sive : 9/12 : 9m] is in the lobby and there are 2/3 other games in progress.
[07:24:26 PM] <To your friends> !getgames
[07:24:26 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:24:41 PM] <To your friends> !getgames
[07:24:41 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:24:56 PM] <To your friends> !getgames
[07:24:56 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:25:11 PM] <To your friends> !getgames
[07:25:12 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:25:27 PM] <To your friends> !getgames
[07:25:27 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:25:42 PM] <To your friends> !getgames
[07:25:42 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:25:57 PM] <To your friends> !getgames
[07:25:57 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[07:26:12 PM] <To your friends> !getgames
[07:26:12 PM] <From TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.





EDIT: Ok, after quite a bit of testing, it's way to buggy, half the time when .games is performed it won't list the games that are open, and the other half the time it does, another bug, it keeps doing /f msg non stop, even when all bots are in channel, possible cause is one bot isn't talking to it yet and it goes into a loop till this bot does.

Another glitch, on the [private const vdisplay2 = "No games available."] if I change it to [private const vdisplay2 = "No games available, please wait till the bot announces a new one."] it will cut off most of the wording.

So back to 0.6 for me....

This post has been edited by charles_scott: Jun 18 2009, 06:19 PM


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 19 2009, 04:28 AM
Post #4


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



Thanks charles_scott will be looking at these problems and will be adding some futures for example if all bots is in channel it wont "/f m"

Updated Thanks to phix.

This post has been edited by Call: Jun 19 2009, 04:29 AM


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
thevoden
post Jun 19 2009, 07:33 AM
Post #5


Jr. Member
**

Group: Members
Posts: 19
Joined: 29-May 09
Member No.: 51,053



I am using your older gHL since I'm completely satisfied with it (and i dont have multiple bots).

I was wondering if you can explain the

vinterval
vtimerinterval

and how it works

I set vtimerdisplay=1
vtimerinverval = 20
vtimerinverval = 20


Then it displays the message twice example:

Bot: <rdlc30>
Bot: <rdlc30>

i set vtimerinterval to 0 and kept vdisplay = 1 and it all works now. Why would one need to use vtimerinterval and vinterval?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 19 2009, 07:53 AM
Post #6


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(thevoden @ Jun 19 2009, 03:33 PM) *

I am using your older gHL since I'm completely satisfied with it (and i dont have multiple bots).

I was wondering if you can explain the

vinterval
vtimerinterval

and how it works

I set vtimerdisplay=1
vtimerinverval = 20
vtimerinverval = 20


Then it displays the message twice example:

Bot: <rdlc30>
Bot: <rdlc30>

i set vtimerinterval to 0 and kept vdisplay = 1 and it all works now. Why would one need to use vtimerinterval and vinterval?


its a little bug and the new version should work like the old just a bit better smile.gif


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 19 2009, 11:12 AM
Post #7


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Thanks, it seems to work MUCH MUCH better now, ran into a RANDOM glitch, and I can't replicate it for the sake of my life... That and for some reason my Beta bot stoped logging text again..

Anyways, the glitch went similar to this, and I can't replicate it, so something else may have caused it.


EDIT: NVM, finaly someone managed to get it to glitch and do it all over again... Only way to fix is to restart bot...

QUOTE


[01:07:01 PM] <Skineemikee> .games
[01:07:01 PM] <Jus_a_ICe_Trol> no wai i was outrunnin that
[01:07:02 PM] <arankaruvaizard> island troll tribes!-
[01:07:07 PM] -- arankaruvaizard has left the channel.
[01:07:13 PM] <Skineemikee> .games
[01:07:14 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes TwGB #7(12/12/6m)
[01:07:19 PM] <C0RR0SIVE[TWGB]> Games: Games: Island Troll Tribes TwGB #7(12/12/6
[01:07:20 PM] -- Jus_a_ICe_Trol has left the channel.
[01:07:24 PM] -- Jus_a_ICe_Trol [47ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 17, icon tier Undead, destroyer icon, in clan TwGB).
[01:07:34 PM] -- Jus_a_ICe_Trol has left the channel.
[01:08:33 PM] -- Skineemikee has left the channel.
[01:09:08 PM] -- SpankDaHobo [94ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 0, icon tier Random, peon icon, in clan TwGB).
[01:11:39 PM] -- chubbthehippo [125ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 1, icon tier Random, peon icon).
[01:11:45 PM] <chubbthehippo> .games
[01:11:46 PM] <C0RR0SIVE[TWGB]> Games: Games: Games: Island Troll Tribes TwGB #7(12/12
[01:12:13 PM] <chubbthehippo> .games
[01:12:14 PM] <C0RR0SIVE[TWGB]> Games: Games: Games: Games: Island Troll Tribes TwGB #7(12/
[01:12:16 PM] <chubbthehippo> .games
[01:12:19 PM] <chubbthehippo> .games
[01:12:22 PM] <chubbthehippo> .games
[01:12:51 PM] <C0RR0SIVE[TWGB]> lol
[01:13:07 PM] <C0RR0SIVE[TWGB]> it glitched again smile.gif
[01:13:12 PM] <BLisS-DarKEyeS> =\
[01:13:13 PM] <BLisS-DarKEyeS> lol
[01:13:21 PM] <C0RR0SIVE[TWGB]> bliss type .games
[01:13:26 PM] <BLisS-DarKEyeS> .games
[01:13:26 PM] <C0RR0SIVE[TWGB]> Games: Games: Games: Games: Games: Island Troll Tribes TwGB #7(1
[01:13:30 PM] <BLisS-DarKEyeS> nah its good
[01:13:31 PM] <C0RR0SIVE[TWGB]> yep it glitched
[01:13:34 PM] <BLisS-DarKEyeS> did it?
[01:13:36 PM] <BLisS-DarKEyeS> oh
[01:13:38 PM] <BLisS-DarKEyeS> haha
[01:13:40 PM] <C0RR0SIVE[TWGB]> its saying games: games: games:
[01:13:41 PM] <C0RR0SIVE[TWGB]> lol
[01:13:44 PM] <BLisS-DarKEyeS> chubb was spaming it
[01:13:45 PM] <BLisS-DarKEyeS> rofl
[01:13:48 PM] <BLisS-DarKEyeS> probly why
[01:13:50 PM] <BLisS-DarKEyeS> hahah
[01:13:51 PM] <C0RR0SIVE[TWGB]> nope
[01:13:57 PM] <C0RR0SIVE[TWGB]> well yea
[01:13:58 PM] <C0RR0SIVE[TWGB]> but its good
[01:14:06 PM] <C0RR0SIVE[TWGB]> as i was trying to replicate the freaking glitch....


This post has been edited by charles_scott: Jun 19 2009, 11:18 AM


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Ribose
post Jun 19 2009, 12:03 PM
Post #8


So, it's all about fame, huh?
*****

Group: Global Moderators
Posts: 2,950
Joined: 13-February 06
From: Connecticut, USA. (GMT -5:00)
Member No.: 74



Call:
CODE
if not ghlL = vdisplay2 then ghlL = "Games: " & left(ghlL, len(ghlL) - 2)
This global variable is being modified every time it is displayed to be prefixed and trimmed at the end. To avoid this, use a private variable...


--------------------
~Ribose
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
vjain
post Jun 19 2009, 08:24 PM
Post #9


Rookie
*

Group: Members
Posts: 8
Joined: 8-April 09
Member No.: 48,979



I'm probably doing something really stupid, but I can't seem to get this plugin working properly. The plugin IS imported (/phelp ghl works), but .games does not (. being my trigger). It gives no output, the bot doesn't do anything inside itself (doesn't whisper, etc).

CODE

The only thing I've changed in the bot are the following lines:
private const vghost = "V-Bot"                              'Ghost's username seperate with |
private const vghostcommand = "!getgames"                       'Command to whisper
private const vcommand = "games"                           'Command to display new games


This post has been edited by vjain: Jun 19 2009, 08:26 PM
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 20 2009, 12:11 AM
Post #10


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(vjain @ Jun 20 2009, 04:24 AM) *

I'm probably doing something really stupid, but I can't seem to get this plugin working properly. The plugin IS imported (/phelp ghl works), but .games does not (. being my trigger). It gives no output, the bot doesn't do anything inside itself (doesn't whisper, etc).

CODE

The only thing I've changed in the bot are the following lines:
private const vghost = "V-Bot"                              'Ghost's username seperate with |
private const vghostcommand = "!getgames"                       'Command to whisper
private const vcommand = "games"                           'Command to display new games



do you have the bot on friend list?


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
vjain
post Jun 20 2009, 01:19 AM
Post #11


Rookie
*

Group: Members
Posts: 8
Joined: 8-April 09
Member No.: 48,979



QUOTE(Call @ Jun 20 2009, 02:11 AM) *

QUOTE(vjain @ Jun 20 2009, 04:24 AM) *

I'm probably doing something really stupid, but I can't seem to get this plugin working properly. The plugin IS imported (/phelp ghl works), but .games does not (. being my trigger). It gives no output, the bot doesn't do anything inside itself (doesn't whisper, etc).

CODE

The only thing I've changed in the bot are the following lines:
private const vghost = "V-Bot"                              'Ghost's username seperate with |
private const vghostcommand = "!getgames"                       'Command to whisper
private const vcommand = "games"                           'Command to display new games



do you have the bot on friend list?


Yes, I have it as mutual. I hope that isn't the issue...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 20 2009, 12:48 PM
Post #12


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Nvm, but the mutual doesn't matter, have you added the stealthbot to the ghost bot userlist? Also I think the stealthbot has to be a Warcraft 3 bot, that way ghost wispers back properly, and it only wispers if the ghostbot isn't in the channel.

This post has been edited by charles_scott: Jun 20 2009, 12:50 PM


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Men_Of_Greece
post Jun 20 2009, 01:14 PM
Post #13


Full Member
***

Group: Members
Posts: 142
Joined: 23-October 06
From: Washington
Member No.: 10,818



does this topic provide any help on running GHost One hosting bot?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
PhiX
post Jun 20 2009, 01:53 PM
Post #14


Notice the ownage.
********

Group: Global Moderators
Posts: 10,862
Joined: 15-January 07
From: GeRmAnY (GMT +1:00)
Member No.: 16,204



QUOTE(Men_Of_Greece @ Jun 20 2009, 09:14 PM) *
does this topic provide any help on running GHost One hosting bot?
No. It's a StealthBot script, nothing more.


--------------------
PhiX
--------------------
I do not provide support via PM or IM, please use the forums.
SBs Help Tool - Please only double click my name if I told you to do so.
--------------------

Whore of Clan BoT

JBLS: phix.no-ip.org (click for stats) IPB Image
--------------------
QUOTE(Clan BoT)
[20:33:50.063] <[email protected]> I'm not showing any respect to a bunch of script kiddie faggots.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 20 2009, 04:15 PM
Post #15


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Go to codelain.com for help on that.

But I guess a previous bug is back, or has resurfaced in a different manor.

After awhile the script seems to not update when the bots are in the channel, all games will be used, bots in channel, but when someone types .games, it reports that a game is open.

QUOTE
[06:14:22 PM] <c0rr0sive> .games
[06:14:23 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes TwGB #10(9/12/5m)
[06:14:25 PM] <c0rr0sive> .getgames
[06:14:25 PM] <TwGB[Host]> There is no game in the lobby and there are 3/3 other games in progress.
[06:14:28 PM] <c0rr0sive> .games
[06:14:31 PM] <c0rr0sive> .games
[06:14:31 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes TwGB #10(9/12/5m)


This post has been edited by charles_scott: Jun 20 2009, 04:15 PM


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 20 2009, 04:27 PM
Post #16


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



it looks like your using something else because it would say send to your friends if your using 2.3

nvm thanks scott i discovered it when it dont sent the update .getgames because all listed bots are in channel it wont update the game list. (Updating to 2.4 soon)Attached File  ghl2.plug ( 5.63k ) Number of downloads: 251


This post has been edited by Call: Jun 20 2009, 04:36 PM


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 20 2009, 04:35 PM
Post #17


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Ok, I was curious, I am using the 2.7 RC1, I just now noticed it didn't do it, as the Ghost bot said wispered back right as the game had started that no other games were in progress.


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 20 2009, 04:46 PM
Post #18


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(charles_scott @ Jun 21 2009, 12:35 AM) *

Ok, I was curious, I am using the 2.7 RC1, I just now noticed it didn't do it, as the Ghost bot said wispered back right as the game had started that no other games were in progress.


tell me if u find any more bugs smile.gif


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 20 2009, 10:43 PM
Post #19


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



It still seems to be having issues with updating it self, it sometimes wont report when a game is in lobby, even though it asks ghost and the ghost program returns the game information... It is all very random when this does happen... I wish I could be of more help...


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
vjain
post Jun 21 2009, 02:37 PM
Post #20


Rookie
*

Group: Members
Posts: 8
Joined: 8-April 09
Member No.: 48,979



Reinstalled Stealthbot and now it works.

Thanks for the script!
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 26 2009, 10:42 AM
Post #21


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Hey, Call, after a lot of testing this latest script out, it still seems to have issues after a few hours and games are gone by... Someone can type .games, and there has been a new game open for 5 minutes but it will still state no new games... And vice versa, this happens about every 6-12 hours for me, it seems more dependent on how many games go through in an amount of time.

I have found, reloading the script every few hours seems to fix the issue, so it may not be an issue with the script it self, or it is only something in the 2.7 RC1 that is causing this.


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jun 26 2009, 10:48 AM
Post #22


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(charles_scott @ Jun 26 2009, 06:42 PM) *

Hey, Call, after a lot of testing this latest script out, it still seems to have issues after a few hours and games are gone by... Someone can type .games, and there has been a new game open for 5 minutes but it will still state no new games... And vice versa, this happens about every 6-12 hours for me, it seems more dependent on how many games go through in an amount of time.

I have found, reloading the script every few hours seems to fix the issue, so it may not be an issue with the script it self, or it is only something in the 2.7 RC1 that is causing this.


i have 2.7 rc1 (where i test plugins) because it can give me specific line and not some random error i gotta look up tongue.gif but i cant reproduce this error, i might have some spare time next week to look true the /f m timer smile.gif


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jun 26 2009, 10:55 AM
Post #23


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Hey, it just happened, its very random at start but gets more consistant later on.

QUOTE

[12:52:21 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #3 : : 1/12 : 3m] is in the lobby and there are 2/3 other games in progress.
[12:52:32 PM] -- Gogoaw [32ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 0, icon tier Human, rifleman icon, in clan TwGB).
[12:52:33 PM] <To your friends> .getgames
[12:52:34 PM] -- Skineemikee [109ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 0, icon tier Random, peon icon, in clan TvGB).
[12:52:38 PM] <Gogoaw> .games
[12:52:39 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #3 : : 0/12 : 3m] is in the lobby and there are 2/3 other games in progress.
[12:52:39 PM] <C0RR0SIVE[TWGB]> No games available, please wait till TwGB[Host] announces one.
[12:52:48 PM] -- Gogoaw has left the channel.
[12:52:52 PM] <To your friends> .getgames
[12:53:03 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #3 : : 3/12 : 4m] is in the lobby and there are 2/3 other games in progress.
[12:53:07 PM] -- Skineemikee has left the channel.
[12:53:12 PM] <c0rr0sive> .games
[12:53:12 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes TwGB #3(3/12/4m)
[12:53:14 PM] <To your friends> .getgames
[12:53:16 PM] <c0rr0sive> lmfao wtf


Also note, the hostbot isn't in the channel


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jul 8 2009, 07:35 PM
Post #24


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



2.6 seems to be working great now that it doesnt get rid of the old game once .getgames is issued again. I will keep an eye for anymore "bugs"

Well, hell, previous bug seems to be back, now that I am running multiple bots, if a bot doesnt reply in time when .getgames is issued from the bot, and someone types .games, it wont list the game...

QUOTE
[10:19:25 PM] <To your friends> !getgames
[10:19:26 PM] <Turpin> .mosttoday
[10:19:26 PM] -- c0rr0sive [31ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 20, icon tier Night Elf, druid of the talon icon, in clan TwGB).
[10:19:26 PM] <C0RR0SIVE[TWGB]> 123 unique users have joined the channel today.
[10:19:27 PM] <c0rr0sive> .games
[10:19:28 PM] <C0RR0SIVE[TWGB]> No games available, please wait till a hostbot announces one.
[10:19:28 PM] <From TwGB[hostbot]> Game [Island Troll Tribes - TwGB #15 : : 9/12 : 49m] is in the lobby and there are 0/20 other games in progress.
[10:19:32 PM] <c0rr0sive> .games
[10:19:33 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes - TwGB #15(9/12/49m)
[10:19:34 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #4 : man_lord : 0/12 : 35m] is in the lobby and there are 1/3 other games in progress.
[10:19:38 PM] <c0rr0sive> .games
[10:19:38 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes - TwGB #15(9/12/49m), Island Troll Tribes TwGB #4(0/12/35m)
[10:19:41 PM] <c0rr0sive> lol
[10:19:42 PM] <c0rr0sive> wtf
[10:19:42 PM] -- January has left t


This post has been edited by charles_scott: Jul 8 2009, 08:20 PM


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jul 9 2009, 05:01 AM
Post #25


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(charles_scott @ Jul 9 2009, 03:35 AM) *

2.6 seems to be working great now that it doesnt get rid of the old game once .getgames is issued again. I will keep an eye for anymore "bugs"

Well, hell, previous bug seems to be back, now that I am running multiple bots, if a bot doesnt reply in time when .getgames is issued from the bot, and someone types .games, it wont list the game...

QUOTE
[10:19:25 PM] <To your friends> !getgames
[10:19:26 PM] <Turpin> .mosttoday
[10:19:26 PM] -- c0rr0sive [31ms] has joined the channel using WarCraft III: The Frozen Throne (Level: 20, icon tier Night Elf, druid of the talon icon, in clan TwGB).
[10:19:26 PM] <C0RR0SIVE[TWGB]> 123 unique users have joined the channel today.
[10:19:27 PM] <c0rr0sive> .games
[10:19:28 PM] <C0RR0SIVE[TWGB]> No games available, please wait till a hostbot announces one.
[10:19:28 PM] <From TwGB[hostbot]> Game [Island Troll Tribes - TwGB #15 : : 9/12 : 49m] is in the lobby and there are 0/20 other games in progress.
[10:19:32 PM] <c0rr0sive> .games
[10:19:33 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes - TwGB #15(9/12/49m)
[10:19:34 PM] <From TwGB[Host]> Game [Island Troll Tribes TwGB #4 : man_lord : 0/12 : 35m] is in the lobby and there are 1/3 other games in progress.
[10:19:38 PM] <c0rr0sive> .games
[10:19:38 PM] <C0RR0SIVE[TWGB]> Games: Island Troll Tribes - TwGB #15(9/12/49m), Island Troll Tribes TwGB #4(0/12/35m)
[10:19:41 PM] <c0rr0sive> lol
[10:19:42 PM] <c0rr0sive> wtf
[10:19:42 PM] -- January has left t



will fix this soon -.-


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jul 9 2009, 05:46 PM
Post #26


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



Sorry, I guess it is starting to annoy you a bit?

I guess I am also one of the few that use your script a LOT....


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
charles_scott
post Jul 9 2009, 09:24 PM
Post #27


Full Member
***

Group: Sr. Members
Posts: 189
Joined: 12-April 06
Member No.: 3,727



It still seems to be doing it, so I am unsure as to what is going on... I may just use the old script that I had, which is incredibly old...

Is there anyway the script can be done so the bot will re-use the old games it recieved untill it gets an update from the ghostbots?


--------------------
Clan TwGB - Trolls With Guns N' Balls - Island Troll Tribes

Clan TwGB @ Azeroth for autohosted ITT games, use .games to see any open ITT games while there.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Call
post Jul 10 2009, 01:56 PM
Post #28


Posting God
*****

Group: Beta Testers
Posts: 1,423
Joined: 15-June 08
From: Denmark, Copenhagen
Member No.: 38,127



QUOTE(charles_scott @ Jul 10 2009, 05:24 AM) *

It still seems to be doing it, so I am unsure as to what is going on... I may just use the old script that I had, which is incredibly old...

Is there anyway the script can be done so the bot will re-use the old games it recieved untill it gets an update from the ghostbots?


Have been testing 2.8 and the bug u pointed out have been fixed.


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
FoxInTheBox
post Jul 16 2009, 07:45 AM
Post #29


Foxxy
***

Group: Members
Posts: 271
Joined: 10-July 09
Member No.: 52,383



Anyone can help me? I love this plugin but I'd like to make so it prints out in /me text


--------------------
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
PhiX
post Jul 16 2009, 03:36 PM
Post #30


Notice the ownage.
********

Group: Global Moderators
Posts: 10,862
Joined: 15-January 07
From: GeRmAnY (GMT +1:00)
Member No.: 16,204



Change all the "dsp 1" to "dsp 2".


--------------------
PhiX
--------------------
I do not provide support via PM or IM, please use the forums.
SBs Help Tool - Please only double click my name if I told you to do so.
--------------------

Whore of Clan BoT

JBLS: phix.no-ip.org (click for stats) IPB Image
--------------------
QUOTE(Clan BoT)
[20:33:50.063] <[email protected]> I'm not showing any respect to a bunch of script kiddie faggots.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

2 Pages V  1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 14th October 2019 - 08:30 PM
Skin by Andrea
Website Legal Information | Hosted by LunarPages